施用JDK1.7 eclipse報錯 Android requires compiler compliance level 5.0 or 6.0

tags:    時間:2013-12-14 20:31:48
使用JDK1.7 eclipse報錯 Android requires compiler compliance level 5.0 or 6.0.
先說明下,設置編譯等級無法解決此問題。
原項目是在intellij idea中寫的。並且運行正常。但是 idea對UI設計支持的不是很好。所以我導入到了eclipse中。

我代碼中使用了部分1.7特性。例如 switch 使用字元串等等。
如果更改為1.6 
此錯誤消失:
Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Android Tools > Fix Project Properties.

但是代碼中需要大量修改使用了1.7特性的部分。並且switch只能修改為if語句了。

有什麼方法能解決此問題?
eclipse版本:

Eclipse IDE for Java Developers

Version: Juno Service Release 2
Build id: 20130225-0426

ADT版本:

Android DDMS                 21.1.0.v201302060044-569685
Android Development Tools 21.1.0.v201302060044-569685
............
android compiler jdk

------解決方案--------------------
ADT是基於JAVA 1.6 的
------解決方案--------------------
加個編譯說明能不能解決?
------解決方案--------------------
Please use Android Tools > Fix Project Properties.
你按照提示操作一下看看

推薦閱讀文章

Bookmark the permalink ,來源:互聯網