ruby2.0.0 裝配cocoapods 失敗處理方法

tags:    時間:2013-12-22 21:34:37
ruby2.0.0 安裝cocoapods 失敗處理方法

感覺是bundle的版本太老了,當前通過RVM安裝的Bundler的版本是1.1.5
安裝XCode 4.4有沒有問題?沒有問題的話在XCode4.4裡面將Command Line Tools裝好以後,升級一下RVM,然後安裝Ruby 1.9.3-p194吧。

rvm implode

就可以把rvm連同ruby一起卸載調,然後

curl -L https://get.rvm.io | bash -s stable --ruby

就可以一鍵將RVM,Ruby2.0.0p247連同Bundler一起裝好。

重要!
 [b]sudo FLAGS="-F /System/Library/Frameworks" gem install cocoapods -- --with-ldflags="-F/System/Library/Frameworks"[/b]

沒有上面這部必然要出錯

然後
gem install cocoapods


推薦閱讀文章

Bookmark the permalink ,來源:互聯網